Technical help Q & A Got A technical problem with you car? Keep it in here where the techies hang out and we will try to solve it for you!!

For tech advise.. read this first!!

Old 29-10-2004, 10:34 AM
  #1  
Stu @ M Developments
PassionFords Creator

Thread Starter
iTrader: (12)
 
Stu @ M Developments's Avatar
 
Join Date: May 2003
Location: Blackpool, UK Destination: Rev limiter
Posts: 28,800
Received 82 Likes on 66 Posts
Default For tech advise.. read this first!!

All topics that cover very common or very technical subjects are often moved to the Tech essays forum to preserve them for future reference.

This is a Gold members only forum and can be accessed here: https://passionford.com/forum/viewforum.php?f=56

Topics such as:




So its well worth a visit
Stu @ M Developments is offline  
Old 12-11-2004, 08:46 PM
  #2  
deancossie
Virgin
 
Join Date: Nov 2004
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

i have a problem with my escort rs turbo. When i put my foot down the car seems to be holding back and im getting a smell of fuel. if you eaze in the power in it seems to be much better but still not right.Please can someone help
deancossie is offline  
Old 08-09-2005, 04:30 AM
  #3  
dox
Regular Contributor
 
Join Date: Aug 2005
Location: new zealand
Posts: 225
Likes: 0
Received 0 Likes on 0 Posts
Default

hi, are the engine manuals downloadable?
dox is offline  
Old 11-02-2006, 04:05 PM
  #4  
danfrst
Virgin
 
Join Date: Feb 2006
Location: Newport
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Ive got a problem with my fiesta Rst, radiator hose blew so i replaced it, then new one blew few days later. first one had been on car with no problems since i bought it a year ago? any ideas?
danfrst is offline  
Old 23-06-2006, 01:04 PM
  #5  
tintin12
Virgin
 
Join Date: Jun 2006
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Help please

I have a 2.0l Sierra station wagon (later model - Saphire shape).
I have just redone the head after it blew a head gasket (due to poor workmanship of the previous owner)
I have also rebuilt the Weber Carb and have set it up according to the Haynes manual.

I cannot get this thing to run economically. Its currently running at about 6km/l (16l/100km)

What is the typical economy of these cars and does anyone have any suggestions to make it any cheaper to run.

I am from South africa and we are currently paying R6.36/l (or something close to this) for petrol, and this is costing me a fortune to run.

Any help would be apreciated.
tintin12 is offline  
Old 12-07-2006, 01:45 PM
  #6  
k1rky-b0y
15000
 
Join Date: Jul 2006
Location: fife
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Default

av jst got me a oil sep tank bailys with samco hoses jst wonderin how to fit it if any1 can help cheers kirk
k1rky-b0y is offline  
Old 12-07-2006, 01:46 PM
  #7  
k1rky-b0y
15000
 
Join Date: Jul 2006
Location: fife
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Default

o a forgot to say for esc cosy
k1rky-b0y is offline  
Old 17-07-2006, 10:37 AM
  #8  
marko4
Virgin
 
Join Date: Apr 2005
Location: hartlepool
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

i have a problem with my escort rs turbo. When i put my foot down the car seems to be holding back when you hit four thousand revs and loud popping from the exhaust. if you eaze in the power in it seems to be much better but still not right.Please can someone help
marko4 is offline  
Old 05-05-2007, 05:18 PM
  #9  
Naughty But Nice
Virgin
 
Join Date: May 2007
Location: kent
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

hi can admin please change my note under my name from `virgin` to.........
naughty but nice
thanks
Naughty But Nice is offline  
Old 04-04-2008, 08:57 AM
  #10  
SS1
10K+ Poster!!
iTrader: (3)
 
Join Date: Jun 2004
Location: Racing the clouds home
Posts: 13,285
Received 3 Likes on 3 Posts
Default

stu the link you posted is dead now..or needs a update
SS1 is offline  
Old 11-05-2008, 07:44 PM
  #11  
Miller 3
PassionFord Post Whore!!
iTrader: (4)
 
Miller 3's Avatar
 
Join Date: Nov 2006
Location: rainham/kent
Posts: 9,407
Received 12 Likes on 11 Posts
Default

^^^ AS ABOVE ^^^
Miller 3 is offline  
Old 26-06-2008, 09:50 AM
  #12  
Mike0001
Virgin
 
Mike0001's Avatar
 
Join Date: Jun 2008
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Exclamation

By the way, it is tech advice, not tech advise...
Mike0001 is offline  
Old 07-10-2008, 06:56 PM
  #13  
fakelondonboy
EAT MY DUST!!!
 
fakelondonboy's Avatar
 
Join Date: Oct 2008
Location: uk
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default Help What Are The Holes In Footwell

hi, i just wanted to know what are the holes in the footwells of my 3 door cosworth?
they look like vents, can i cover them? looks like thats how water has got in to start rusting it out
,
fakelondonboy is offline  
Old 29-01-2009, 06:29 AM
  #14  
vk6yba
Virgin
 
Join Date: Jan 2009
Location: Perth Western Aust
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi There guys [and guyettes.]

New to this web site, got a 1990 EFI XR3i and need to know the correct ecu for it.

Silly me I forgot to bring the info on them [I have 2] home from work. Never mind someone probably know this anyway.

Thanks in advance vk6yba
vk6yba is offline  
Old 09-08-2009, 09:08 AM
  #15  
adam mander
Virgin
 
Join Date: Aug 2009
Location: congleton
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

hi every 1 got starting prob with my erst starts up but runs lumpy nearly cuts out untill i pull the fuel module out then it ticks over fine can any 1 help me thanks
adam mander is offline  
Old 28-10-2009, 01:49 AM
  #16  
The Homacide
Virgin
 
Join Date: Oct 2009
Location: Northampton
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Hello People
Can anyone help me. I have an Escort GTi MK6 1997 and i need to new clutch. Ive been reading about the IB5 and the BC gearboxes but i popped my bonnet and the number no my gearbox is 96WT 7F096 BA which i found to be a box from a 1.6 16V is this true.
The car seems to run fine with this on but now as the clutch is shot i dont know what clutch to put in this box i assumes its a clutch for a 1.8 but i dont which one everytime i look on tinternet im always prompted with with box BC or IB5 but it aint any of those can anyone sort out this dilemma

Thanks Sorry about the essay.
The Homacide is offline  
Old 14-11-2009, 01:20 PM
  #17  
priestyboy369
Virgin
 
Join Date: Nov 2009
Location: South Wales
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi guys kinda new here. I got an escort RST S2 but my gearbox is shot and have a big BHP rating so dont want to go BC rebuild. Iv heard you can fit a RS2000 gearbox on an S2 with new drive shafts but I dont know where to go with it.. can anyone tell me if they have had a conversion and where they had the work done.??
Thanks guys.
priestyboy369 is offline  
Old 07-01-2010, 07:12 PM
  #18  
aajbarker
massive burnout .com
 
aajbarker's Avatar
 
Join Date: May 2009
Location: essex
Posts: 82
Likes: 0
Received 0 Likes on 0 Posts
Default virgin!

Originally Posted by Naughty But Nice View Post
hi can admin please change my note under my name from `virgin` to.........
naughty but nice
thanks

u can go on ur profile and change it urself
aajbarker is offline  
Old 02-03-2010, 05:22 PM
  #19  
mk6matt_1992
Virgin
 
Join Date: Mar 2010
Location: Cambridge
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi there guys, having a bit of a problem. I'm currently sourcing all of the parts i need to fit my S2 ERST engine into my mk 6 escort and i'm having trouble deciding on a gearbox to use (have been informed that you can use a 1.8 TDI escort box, but i'm unsure of this). Any advice much appreciated
mk6matt_1992 is offline  
Old 17-04-2010, 08:33 AM
  #20  
mike blake
Virgin
 
Join Date: Apr 2010
Location: crewe
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default please help

i have a fieata style 06 registered, with a manual gearbox having done aprpox 45,000 miles, i had the clutch replaced by a garage then within two weeks lost fifth and reverse gears, there was or is no noise from the gearbox to indicate a problem and the gear lever moves into position normaly but when the clutch is released there is no drive, , any ideas?
mike blake is offline  
Old 17-04-2010, 08:35 AM
  #21  
mike blake
Virgin
 
Join Date: Apr 2010
Location: crewe
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

by the way hello, and thanks in anticipation,
mike blake is offline  
Old 24-05-2010, 08:33 AM
  #22  
m nicol
Virgin
 
Join Date: May 2010
Location: new zealand
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

were wood i find the pats reciever and or sensors on a 97 ford mondeo 2.0
m nicol is offline  
Old 01-09-2010, 10:49 PM
  #23  
bennie12340
Virgin
 
Join Date: May 2004
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

i have a fiesta 1300cc with an endura-e engine 2001.number 6 push rod keeps jumping off the tappett.i have changed the push rods and rocker shaft & it still jumps off. is it possible it could be a sticky valve or a cam follower. if it is a cam follower do they go in the top or the bottom of the engine.when the engine is running it sounds perfect, when it jumps off you get a popping through the injection box on the top of the engine. can anyone help. cheers
bennie12340 is offline  
Old 29-11-2010, 02:24 PM
  #24  
irishdonkey
Virgin
 
Join Date: Nov 2010
Location: West Midlands
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Question Ford Mondeo 2.0 TDCI - (2003 New Look)

I have a 2003 2L Diesel TDCi Mondeo (new look) which has some intermittent problems which I am struggling to pin down and I am hoping somebody can point me in the right direction as I have already paid a garage to look at the computer which gave me no help at all..

It seems to be a problem with Electrics but I'm not sure.

When I use the 'open' button on the key fob..... it opens everything except the Drivers Door and the Boot. I can open the driver's door with the key which also unlocks the boot. I have tried to change the sequence but this has no effect.

Also recently (in this cold weather) another problem has shown itself intermittently. When I start the car the Wipers, Electric Windows and Blower have no power going to them. This comes on after 5 mins of waiting on the windows to clear.

There is also a flashing of the Air Bag light, which sometimes stays on and sometimes continues to flash.

Are all these issues related? i.e. do they all go through one relay or wiring loom? Can somebody point me in the right direction to start investigating?
irishdonkey is offline  
Old 06-01-2011, 04:55 PM
  #25  
johan anderson
Virgin
 
Join Date: Jan 2011
Location: glencoe kzn sa
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

i have a problem with a focus st 170. fuel pressure drops under driving conditions and cuts out @roughly 4000rpm.i have changed the fuel pump and filter, it goes better but problem is still their? please help any suggestions
johan anderson is offline  
Old 01-03-2011, 11:18 AM
  #26  
Jaygo.1
Virgin
 
Join Date: Jan 2010
Location: bingham, notts
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Ford escort mk4 xr3i cabroilat

I have had my escort for two years now, and rescently had to change the engine, The car seems to have the habbit of running fine from cold if i stop the engine every now and again it will play up,sounding tight when turning over or as if the batterys flat, how ever i leave it for harf an hour it strikes straight up.
To try and remidy this problem i have changed the starter motor, swapped the battery checked altenater Its now getting to the point were im going to scream and scrap the thing
And advice would be well taken on bored
Cheers Jason
Jaygo.1 is offline  
Old 01-03-2011, 11:33 AM
  #27  
saph4be
PassionFord Post Whore!!
 
Join Date: Jan 2007
Location: mansfield
Posts: 3,584
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Jaygo.1 View Post
I have had my escort for two years now, and rescently had to change the engine, The car seems to have the habbit of running fine from cold if i stop the engine every now and again it will play up,sounding tight when turning over or as if the batterys flat, how ever i leave it for harf an hour it strikes straight up.
To try and remidy this problem i have changed the starter motor, swapped the battery checked altenater Its now getting to the point were im going to scream and scrap the thing
And advice would be well taken on bored
Cheers Jason
sounds like your timing is out to me
saph4be is offline  
Old 01-03-2011, 03:34 PM
  #28  
Jaygo.1
Virgin
 
Join Date: Jan 2010
Location: bingham, notts
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by saph4be View Post
sounds like your timing is out to me
Cheers would that ignition or valve by any chance?
Jaygo.1 is offline  
Old 19-04-2011, 10:29 AM
  #29  
ob8
Virgin
 
Join Date: Apr 2011
Location: south africa
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi I'm new here, have a ford bantam (xr4 pick-up) with a 2.0 zetec conversion, busa bike throttles st170 injectors and intake, managed by gotech pro-X ecu everything's diy. Having trouble balancing throttles, I've built a carb balance tool with some transparent fish-tank tubing and t pieces using atf as the fluid. Problem is I'm getting it to sync at idle but not at 4500 rpm its either one rev range or the other. Any help would be greatly appreciated. Thanks
ob8 is offline  
Old 14-06-2011, 10:07 AM
  #30  
popi-cupra
Virgin
 
Join Date: Jun 2011
Location: Greece
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

That mustn't be the right topic, I'm writting to, but I would like to ask you, if there is something similar like the "vag com" that group vag has to log their cars! If so, how do you call it? (I need it for focus rs mk2) and where can i buy it? Do you have any url? Thanx a lot for your time!!!
popi-cupra is offline  
Old 23-06-2011, 06:50 PM
  #31  
Geof Gough
Virgin
 
Join Date: Jun 2011
Location: Bayworth
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Could you please show me the layout of the drive belt on a fiesta 1.25
Geof Gough is offline  
Old 06-03-2012, 06:37 PM
  #32  
wl52woz
Virgin
 
Join Date: Mar 2012
Location: wigton
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default focus st problems

i have a focus at the turbo went so i replaced it. no i have some engine fault codes p2127 p2178 p0087 could anyone tell me what these codes mean and if there is anyway of fixing the problems?
wl52woz is offline  
Old 02-04-2012, 11:24 PM
  #33  
Daz1974
Virgin
 
Join Date: Apr 2012
Location: Bristol
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi can anyone tell me where the speed output is on a s2 rs turbo just fitted a I'd power meter need to wire it to that

Last edited by Daz1974; 02-04-2012 at 11:26 PM.
Daz1974 is offline  
Old 02-04-2012, 11:25 PM
  #34  
Daz1974
Virgin
 
Join Date: Apr 2012
Location: Bristol
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Sorry coming out of the ecu
Daz1974 is offline  
Old 12-02-2013, 06:38 PM
  #35  
St170_88
Virgin
 
Join Date: Feb 2013
Location: Bournemouth
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Someone please help me..

I have a 52 plate st170, I changed the clutch and DMF yesterday because it was slipping, but it's STILL slipping. Any ideas what it could be?
St170_88 is offline  
Old 26-04-2013, 09:38 AM
  #36  
welshy2
Virgin
 
Join Date: Apr 2013
Location: kent
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi everyone, hope someone can help, i have a 2006 focus 1.6 petrol, the engine has sucked in water & hydro locked, so i want to replace it, the engine code is HWDA, i am having a bit of trouble finding a good low mileage one, but have been offered a 2008 SDHA one, does anyone know if this is compatible or what other engine codes are. ?? thanks guys
welshy2 is offline  
Old 02-08-2013, 01:24 PM
  #37  
allymac197
Virgin
 
Join Date: Jul 2013
Location: Oxford
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Advice Needed

Hi all, I have a 2003 Mondeo ST220 and I had the fuel pump replaced a couple of months ago. After I picked it up it seemed to be down on power, and it turned out that one of the hoses going into the fuel pump was loose... The AA came out and re-fitted it and the power all came back, but gradually over time the power has dropped off again....

I have checked all the connections into the fuel pump and they are all well sealed and there are no leaks etc. The car has recently had a service and there are no signs of leaks or faults in the engine.

Has anyone any clues at all as to what could cause this, it feels like its not getting enough fuel into the engine to get to full power, but with a brand new fuel pump etc i'm confused as to where i could be losing pressure? Theres no loss of compression in the engine either?
allymac197 is offline  
Old 12-05-2016, 07:09 PM
  #38  
Billy Walker
Virgin
 
Join Date: May 2016
Location: north wales
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Dashboard

Hi I have a mk2 escort is it possible to fit a mk1 escort 6 dial dash board in place of the mk2 dash
Billy Walker is offline  
Old 04-06-2016, 07:23 PM
  #39  
Billy Walker
Virgin
 
Join Date: May 2016
Location: north wales
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Mercedes

If the car is faulty I would say it's not of merchanabe quality and wouldn't think it was fit for purpose the car is not that old so I would not say it would be a ware and tear issue there are cars on the road many years old with original fitted parts and are not worn out I would stick to you guns and say you want a replacement or your money back as you have no faith in the car as I have said you don't buy a newish car and have to buy new parts so soon have the factory fitted poor quality parts good luck and don't let them talk you into paying for parts or a good will gesture unless it's in your favour
Billy Walker is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
A9TUE
Music & Car Audio Chat
3
03-09-2017 01:24 PM
nicodinho
Ford Non RS / XR / ST parts for sale.
6
07-10-2015 12:56 PM
mark94
Ford Mondeo Including ST
3
02-10-2015 03:00 PM
Iain Mac
General Car Related Discussion.
7
30-09-2015 09:39 PM
20/20 vision
General Car Related Discussion.
3
29-09-2015 11:27 AM


Thread Tools
Search this Thread
Quick Reply: For tech advise.. read this first!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.