PassionFord      


Go Back   PassionFord > Tuning, FAQ & Post Archive's. > Technical help Q & A
Sign in using an external account
Register Forgot Password?
Register Photos KBase Gold & Trader Accounts FAQ Search Today's Posts Mark Forums Read GarageVendors
Search
Welcome to PassionFord

Technical help Q & A Got A technical problem with you car? Keep it in here where the techies hang out and we will try to solve it for you!!

Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 03-01-2010, 04:30 PM   #1
stevos
I've found that life I needed.. It's HERE!!
 
Trader Score: (0)
Join Date: Nov 2007
Location: BONNY SCOTLAND
Posts: 1,119
Rep Power: 8
stevos is on a distinguished road
Default Mk 6 fiesta ABS and speedo problems (HELP)

As above problem started when the abs light came on about 2 weeks ago due to it being christmas didn't have a chance to get the car looked at.
Went out and drove acr today only to find that the speedo is no longer working and the engine management light is on.
If anyone has any ideas what it could be any help would be greatly appreciated.
If you were logged in, you wouldn't be seeing this ad!
Register your free account today, or log in if you already have an account.
__________________
stevos is offline   Reply With Quote
Old 03-01-2010, 04:37 PM   #2
martysmartie
PassionFord Post Whore!!
 
martysmartie's Avatar
 
Trader Score: (1)
Join Date: Dec 2007
Posts: 7,254
Rep Power: 15
martysmartie will become famous soon enoughmartysmartie will become famous soon enough
Default

Check the VSS.

Martin
martysmartie is offline   Reply With Quote
Old 03-01-2010, 04:42 PM   #3
stevos
I've found that life I needed.. It's HERE!!
 
Trader Score: (0)
Join Date: Nov 2007
Location: BONNY SCOTLAND
Posts: 1,119
Rep Power: 8
stevos is on a distinguished road
Default

Hi martin not wanting to sound stupid mate but is that the speed sensor.
Would i be looking for it being broken or corroded.
__________________
stevos is offline   Reply With Quote
Old 03-01-2010, 04:54 PM   #4
martysmartie
PassionFord Post Whore!!
 
martysmartie's Avatar
 
Trader Score: (1)
Join Date: Dec 2007
Posts: 7,254
Rep Power: 15
martysmartie will become famous soon enoughmartysmartie will become famous soon enough
Default

Correct, yes check the connections to it, to test it you really need a ocilliscope, some try using an AC voltmeter but you need to test when car is moving. Pretty sure it will be this.

The best way would be to use the self diagnosics on the car, hold in the trip counter and turn ignition to on position and hold a "Gauge Sweep" will be performed (Will reset trip meter but no biggie, will NOT reset total millage) and all dials will go to max and then back to 0 if you keep pressing the trip counter you will get to one on the display think it's number 6 where "DTC" will be displayed on the LCD (Diagnostic Trouble Code) it should display a code here if you can post the code back that will defently tell you the problem. Im 99.9% sure this will work on your car as not knowing Fiesta that well but it certainly works on Focus/Mondeo.

Martin
martysmartie is offline   Reply With Quote
Old 03-01-2010, 05:20 PM   #5
stevos
I've found that life I needed.. It's HERE!!
 
Trader Score: (0)
Join Date: Nov 2007
Location: BONNY SCOTLAND
Posts: 1,119
Rep Power: 8
stevos is on a distinguished road
Default

Thanks mate will giev it try after my dinner.
__________________
stevos is offline   Reply With Quote
Old 03-01-2010, 07:33 PM   #6
stevos
I've found that life I needed.. It's HERE!!
 
Trader Score: (0)
Join Date: Nov 2007
Location: BONNY SCOTLAND
Posts: 1,119
Rep Power: 8
stevos is on a distinguished road
Default

Did the check and got the following codes:
DTC 1-E200
DTC 2-E197
DTC 3-C121
__________________
stevos is offline   Reply With Quote
Old 03-01-2010, 09:59 PM   #7
martysmartie
PassionFord Post Whore!!
 
martysmartie's Avatar
 
Trader Score: (1)
Join Date: Dec 2007
Posts: 7,254
Rep Power: 15
martysmartie will become famous soon enoughmartysmartie will become famous soon enough
Default

Thats the dash programming code, a DTC is made up of 4 digits with a letter before it you should see DTC on the display then underneath the codes will be displayed it may just flash "No code" as this only shows basic faults and can not pick up codes like a scanner could.

Martin
martysmartie is offline   Reply With Quote
Old 04-01-2010, 12:20 AM   #8
stevos
I've found that life I needed.. It's HERE!!
 
Trader Score: (0)
Join Date: Nov 2007
Location: BONNY SCOTLAND
Posts: 1,119
Rep Power: 8
stevos is on a distinguished road
Default

Thanks martin mate don't know if they are related or not have read a few posts on the internet with people having the exact same problems with abs and speedo but no one has said what it was that was causing it.
__________________
stevos is offline   Reply With Quote
Old 17-01-2010, 01:36 PM   #9
murrayb
Virgin
 
Trader Score: (0)
Join Date: Jan 2010
Location: East Lothian
Posts: 1
Rep Power: 0
murrayb is on a distinguished road
Default

I've had exact same problem this week on our 56 fiesta, started with ABS light then also had brake warning light before losing the speedo and counters.
It is working OK now, but would imagine it will probably happen again soon.

I also got the E200 and E197 when in test, but also got the dtc code r0120 which I can't seem to find any info about anywhere?

Any ideas what that code could be?

Cheers

Murray
murrayb is offline   Reply With Quote
Old 17-01-2010, 03:49 PM   #10
andy milligan
newbe
 
andy milligan's Avatar
 
Trader Score: (0)
Join Date: Nov 2009
Location: surrey
Posts: 58
Rep Power: 5
andy milligan is on a distinguished road
Default

Sounds like one of the wheel speed sensors has gone down, not knowing fiestas couldnt tell you which one, on later cars generally there is no speedo cable and the abs sensor will tell the abs ecu the speed and that will be relayed to the dash in some way. If the abs sensor is faulty the the abs light will come on but now its been a while I would suspect that the engine ecu or instruments have recorded a fault causing the eml to come on and no speedo working.
Cant be 100 certain as said not knowing the fiesta electrics. A diag test should shed some more light if the self test has not helped.
Hope you get to the bottom of your problem.
andy milligan is offline   Reply With Quote
Old 13-08-2010, 07:51 PM   #11
magicpie78
Virgin
 
Trader Score: (0)
Join Date: Aug 2010
Location: Plymouth
Posts: 7
Rep Power: 0
magicpie78 is on a distinguished road
Default Ford Fiesta 2006 1.4 ABS Faults

Hi i really need some help. My Wife's Fiesta has developed a fault with several lights coming on. ABS, Engine and the Speedo has stopped working. A friend ran a diagnostic test which showed 7 error codes one of which was the rear sensors not sending info. Ford have quoted a £1000 to repair but i don't have that kind of cash available. I have read that there could be a number of different reasons why this has happened, can anybody be of any assistance?

Regards

Robert
magicpie78 is offline   Reply With Quote
Old 25-01-2013, 10:40 AM   #12
craig_southampton
I'm Finding My Feet Here Now
 
Trader Score: (0)
Join Date: Oct 2009
Location: southampton
Posts: 104
Rep Power: 5
craig_southampton is on a distinguished road
Default

Hello ive got the same problem. did any of you ever fix it? any help would be great thanks.
craig_southampton is offline   Reply With Quote
Old 17-03-2013, 08:54 PM   #13
thebodger
Virgin
 
Trader Score: (0)
Join Date: Feb 2013
Location: hexham
Posts: 1
Rep Power: 0
thebodger is an unknown quantity at this point
Default

Can. You please help.my ford ka speedo does not work.and the engine management light is on.the speedo works through the abs system the diagnostics machine is not reading any faults thanks

Last edited by thebodger; 17-03-2013 at 08:58 PM.
thebodger is offline   Reply With Quote
Old 17-03-2013, 08:54 PM
PassionFord
Ford Focus




Paid Advertisement


 
 
 
submit to reddit
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo problems tabetha Ford Sierra / Sapphire / RS500 Cosworth 3 22-03-2009 02:01 PM
Cossie Speedo problems?? andyevo Technical help Q & A 5 04-03-2007 10:08 PM
Speedo problems Zetecfiesta Ford Escort RS Turbo 3 20-07-2006 06:42 PM
Fiesta RST Speedo, Rear Top Spoiler fernando_khan Ford RS Turbo parts for sale 0 06-06-2006 01:15 AM
speedo problems davecosworth Technical help Q & A 0 25-01-2006 03:28 PM

Advertising - Terms of Service - Privacy Statement - JOBS



All times are GMT. The time now is 01:27 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

Content Relevant URLs by vBSEO 3.5.2