PassionFord      


Go Back   PassionFord > Tuning, FAQ & Post Archive's. > Technical help Q & A
Sign in using an external account
Register Forgot Password?
Search

Technical help Q & A Got A technical problem with you car? Keep it in here where the techies hang out and we will try to solve it for you!!

Welcome to Passion Ford!
Welcome to Passion Ford.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Passion Ford today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 25-09-2008, 07:26 PM   #1
diesel
PassionFord Regular
 
Trader Score: (0)
Join Date: Nov 2007
Location: under the bonnet
Posts: 367
Default fiesta mk4 rear brakes problem

right then my handbrake has been slipping alot lately so i decided to change the rear shoe's.

so on saturday i changed them, put all the drum back together and went to try the handbrake and i was worse than before.(YES I DID TIGHTEN THE HAND BRAKE CABLE)

so i took the drums back off and adjusted the self adjusters so the drum was a tight fitt going back on.

right so i jumped in the car and tested the handbrake and i worked fine, it locked up nice on both wheels screeching the lot, and it left a number 11 on the road happy days.

now here's the problem i drive 3 miles down the road try the handbrake and it's just rubbing abit and no matter how much i tighten the handbrake i doesn,t bit hard. so does any one have any idea's on what is going on

please help as it cooking my head
If you were logged in, you wouldn't be seeing this ad!
Register your free account today, or log in if you already have an account.
diesel is offline   Reply With Quote
Old 26-09-2008, 05:58 AM   #2
tabetha
BANNED
BANNED
 
Trader Score: (0)
Join Date: Jul 2006
Location: uk
Posts: 24,596
Default

Cooking could be the word to use, if you have tightened them too much they could well be overheating if they are in constant contact, try it first thing and see if under normal use the wheel spins freely, the drum doesn't get unduly hot.
tabetha
tabetha is offline   Reply With Quote
Old 26-09-2008, 05:22 PM   #3
diesel
PassionFord Regular
 
Trader Score: (0)
Join Date: Nov 2007
Location: under the bonnet
Posts: 367
Default

thay were smelling for a mile or 2 but it stopped as it took a little layer off.

when i didn't have them rubbing abit thay whouldn't grip, that was the only way thay would work. i didn't menstion that i took them off about 4 times before i could get them to grip.

i dont see why thay would work and then not?
diesel is offline   Reply With Quote
Old 18-04-2009, 02:00 AM   #4
klloyd
Virgin
 
Trader Score: (0)
Join Date: Jun 2006
Location: bury
Posts: 3
Send a message via MSN to klloyd
Default

i have the same problem.but with mine i dont have leaking cylinders but when i try to bleed them nothing comes out.the shoes look ok to me and with the shoes off the cylinder works as it should when i press the pedal.im sure the cylinders are the problem but i just can not be sure
__________________
a passion for fords
klloyd is offline   Reply With Quote
Old 18-04-2009, 02:00 AM
PassionFord
Ford Focus




Paid Advertisement


 
 
 
submit to reddit
Reply

Tags
adjustment, brake, brakes, cable, change, escort, fiesta, ford, hand, handbrake, mk, mk4, rear, tighten, troubleshoot

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MK4 Fiesta FK rear coilovers £85 posted Tank Mike Ford Non RS / XR / ST parts for sale. 7 17-05-2013 06:22 PM
Rear Head Rests 4 Fiesta Mk4 butterfly Cars & Parts Wanted. 0 26-03-2008 07:08 PM
mk4 fiesta rs tubro wiring problem Donk1 Technical help Q & A 1 11-12-2007 04:41 PM
Mk3 & Mk4 rear brakes vroooom ptssssh Ford Escort RS Turbo 28 07-08-2006 08:15 AM
fiesta brakes problem rowen20 Ford Fiesta RS1800 / RS Turbo 2 06-01-2006 01:16 AM

Advertising - Terms of Service - Privacy Statement - JOBS



All times are GMT. The time now is 06:26 AM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

Content Relevant URLs by vBSEO 3.5.2